Unable to access Hue after upgrading

Condition

You are not able to access Hue after upgrading to CDP Private Cloud Base 7.1.8 on a cluster secured using Knox.

Cause

The Hue Load Balancer is not installed and the SetEnv proxy-sendcl configuration is missing.

Solution

  1. Log in to Cloudera Manager as an Administrator.
  2. Add the Hue Load Balancer role instance.
  3. Go to the Configuration tab and add the following line in the Load Balancer Advanced Configuration Snippet (Safety Valve) for httpd.conf field:
    SetEnv proxy-sendcl 1
  4. Click Save Changes.
  5. Restart the Hue Load Balancer and Hue service.