CDP Private Cloud Base Software Requirements

The software requirements for the nodes on which CDP Private Cloud Data Services are deployed are identical to CDP Private Cloud Base.

Your Private Cloud Base cluster must have the operating system, JDK, database, CDP components, and CDP Runtime version compatible with .

You can install your Private Cloud Base cluster independently. Cloudera recommends you to first set up the Private Cloud Base cluster with data and then install the Private Cloud Containerized cluster. To know the requirements for the Private Cloud Base cluster, see CDP Private Cloud Base Requirements and Supported Versions.

Ensure that you have CDP Private Cloud Base 7.1.6 or higher with a Data Lake cluster. (CDP Private Cloud Base 7.1.7 SP1 and Cloudera Manager 7.6.1 are not currently supported with CDP Private Cloud Data Services.) For the Private Cloud Base cluster setup, you can use the latest version of Cloudera Manager 7.5.5.

The following CDP Private Cloud Base cluster services are required to fully assess the Data Services:

  • Hive Metastore (HMS)
  • Ranger
  • Atlas
  • HDFS
  • Ozone
  • YARN
  • Kafka
  • Solr