Prepare CDP Private Cloud Base

Use Cloudera Manager to configure your CDP Private Cloud Base in preparation for the CDP Private Cloud Experiences installation.

  1. Configure the CDP Private Cloud Base cluster to use TLS.
  2. Configure Cloudera Manager with a JKS-format (not PKCS12) TLS truststore.
    For configuration steps, see Database requirements.
  3. Configure Cloudera Manager to include a root certificate that trusts the certificate for all Cloudera Manager server hosts expected to be used with Private Cloud.
    1. Import the necessary certificates into the truststore configured in Configure Administration > Settings > Security > Cloudera Manager TLS/SSL Client Trust Store File.
  4. Configure Ranger and LDAP for user authentication. Ensure that you have configured Ranger user synchronization.
  5. Enable Kerberos for all the services in the cluster.
    For configuration steps, see Enabling Kerberos for authentication.
  6. Configure LDAP using Cloudera Manager. Only Microsoft Active Directory (AD) and OpenLDAP are currently supported.
  7. Check if all the running services in the cluster are healthy. To check this using Cloudera Manager, go to Cloudera Manager > Clusters > [***CLUSTER NAME***] > Health Issues. If there are no health issues, the No Health Issues message is displayed.
  8. Verify if you have the necessary CDP entitlements from Cloudera to access the Private Cloud installation. To check this using Cloudera Manager, go to Cloudera Manager > Private Cloud > Select Repository > [***REPOSITORY URL***]. If you have the required entitlements, the You are about to install CDP Private Cloud version [*VERSION*] message with a list of prerequisites is displayed. An error message is displayed if you do not have the necessary entitlements.
    Contact your Cloudera account team to get the necessary entitlements.
  9. If you want to reuse data from your legacy CDH or HDP deployment in your Private Cloud, ensure that you have migrated that data into your CDP Private Cloud Base. You must be using Cloudera Runtime 7.1.3 or higher for migrating your data from your CDH or HDP cluster.
    For more information about data migration, see the Data Migration Guide.