Installing CDP client

You can install the CDP client through pip on Linux, macOS, or Windows. The CDP client works with Python version 2.7 or version 3.4 or later. Cloudera recommends that you install Python version 3.6 or later.