Solr collections are getting into an inactive state

Know how to troubleshoot when Solr collections go into an inactive state.

Condition

Solr collections are getting into an inactive state and are not able to query.

Cause

Unable to connect to HDFS from Solr when the Kerberos ticket expires on a 24-hour basis.

Remedy

Ensure that you log in to the Cloudera environment as an administrator.

  1. Navigate to Cloudera Manager..
  2. Go to Solr > Configuration > Scope: Solr (Service-Wide) > Category: Advanced > Solr Service Advanced Configuration Snippet (Safety Valve) for core-site.xml
  3. Add the following configurations.
    Key Value
    Name hadoop.kerberos.keytab.login.autorenewal.enabled
    Value true
  4. After making changes, enter a Reason for change, and click Save Changes.
  5. Restart the Solr service (Solr > Actions > Restart) and any dependent services. You can also restart dependent services using the Restart Stale Services wizard.