Apache Solr Search Installation
Also available as:
PDF
loading table of contents...

HDP Search 5.0 Minimum System Requirements

To use HDP Search, your system must meet the following minimum requirements.

HDP Search 5.0 Operating System Requirements

HDP Search 4.0 is supported on the following operating systems:

  • 64-bit CentOS 7

  • 64-bit Red Hat Enterprise Linux (RHEL) 7

JDK Requirements - HDP Search 5.0

HDP Search 5.0 requires Oracle or OpenJDK Java 1.8 or higher.

Make sure your $JAVA_HOME and $PATH variables are set to the correct version; for example:

export JAVA_HOME=/usr/java/default
export PATH=$JAVA_HOME/bin:$PATH

HDP Search 5.0 HDP Requirements

HDP Search 5.0 is tested and certified with HDP 3.0.x and the following HDP components.

ComponentVersion
Apache Hadoop3.1.0
Apache Hive*3.0.0
Apache Pig0.16.0
Apache Spark2.3.1

* We have certified Hive with Tez only and not Map Reduce.