Troubleshooting Cloudera Director
This topic contains information on issues, causes, and solutions for problems you might face when setting up, configuring, or using Cloudera Director.
Viewing Cloudera Director Logs
- Cloudera Director Client
- One shared log file per user account:
$HOME/.cloudera-director/logs/application.log
- One shared log file per user account:
- Cloudera Director Server
- One file for all clusters:
/var/log/cloudera-director-server/application.log
- One file for all clusters:
Backing Up the H2 Embedded Database
/var/lib/cloudera-director-server/state.h2.db
Back up the state.h2.db file to avoid losing environment and cluster data. To ensure that your backup copy can be restored, you should use the H2 backup tools and rather than simply copying the file. For more information, see the H2 Tutorial.
Cloudera Director Cannot Manage a Cluster That Was Kerberized Through Cloudera Manager
Symptom
Cloudera Director cannot manage a cluster after Cloudera Manager is used to enable Kerberos on the cluster.
Cause
Once a cluster is deployed via Cloudera Director, some changes to the cluster that are made using Cloudera Manager cause Cloudera Director to be out of sync, and hence unable to manage the cluster. See Modifying or Updating Clusters Using Cloudera Manager.
New Cluster Fails to Start Because of Missing Roles
Cause
Cloudera Director does not validate that all necessary roles are assigned when provisioning a cluster. This can lead to failures during the intial run of a new cluster. For example, if the gateway instance group was removed but the Flume Agent and Kafka Broker were assigned to roles in that group, the cluster will fail to start.
Cloudera Director Server Will Not Start with Unsupported Java Version
Symptom
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/cloudera/launchpad/Server : Unsupported major.minor version 51.0
Error Occurs if Tags Contain Unquoted Special Characters
Symptom
com.typesafe.config.ConfigException$WrongType: ... <x> has type OBJECT rather than STRING
DNS Issues
Cause
- The Edit DNS Hostnames is not set to Yes the VPC settings.
- The Amazon Virtual Private Cloud (VPC) is not set up for forward and reverse hostname resolution. Functional forward and reverse DNS resolution is a key requirement for many components of the Cloudera EDH platform, including Cloudera Director.
In the AWS Management Console, go to VPC. In the VPC Dashboard, select your VPC and click Action. In the shortcut menu, click Edit DNS Hostnames and click Yes. If this does not fix the issue, continue with the instructions that follow to configure forward and reverse hostname resolution.
and clickpython -c "import socket; print socket.getfqdn(); print socket.gethostbyname(socket.getfqdn())"
For more information on DNS and Amazon VPCs, see DHCP Options Sets in the Amazon VPC documentation.
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Log in to the AWS Management Console.
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Select VPC from the Services navigation list box.
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In the left pane, click Your VPCs. A list of currently configured VPCs appears.
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Select the VPC you are using and note the DHCP options set ID.
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In the left pane, click DHCP Option Sets. A list of currently configured DHCP Option Sets appears.
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Select the option set used by the VPC.
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Check for an entry similar to the following and make sure the domain-name is specified. For example:
domain-name = ec2.internal domain-name-servers = AmazonProvidedDNS
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If it is not configured correctly, create a new DHCP option set for the specified region and assign it to the VPC. For information on how to specify the correct domain name, see the AWS Documentation.
Server Does Not Start
Symptom
The Cloudera Director server does not start or quickly exits with an Out of Memory exception.
Solution
Run Cloudera Director on an instance that has at least 1GB of free memory. See Resource Requirements for more details on Cloudera Director hardware requirements.
Problem When Removing Hosts from a Cluster
Cause
You are trying to shrink the cluster below the HDFS replication factor. See Removing Instances from a Cluster (Note paragraph) for more information about replication factors.
Problems Connecting to Cloudera Director Server
Cause
Configuration of security group and iptables settings. For more information about configuring security groups, see Setting up the AWS Environment. For commands to turn off iptables, see either Installing Cloudera Director Server and Client on the EC2 Instance or Installing Cloudera Director Server and Client on Google Compute Engine. Some operating systems have IP tables turned on by default, and they must be turned off.