Apache Flume Incompatible Changes and Limitations
The CDH Flume version requires to be matched to a minimum Kafka version. This means that if you upgrade to Kafka 2.2, you need to upgrade brokers as well as clients.
- In CDH 5.7 and higher, the Flume connector to Kafka only works with Kafka 2.0 and higher.
- In CDH 5.14 and higher, the Flume connector to Kafka only works with Kafka 2.2 and higher.
We recommend that you have the Kafka broker running the same or newer version as the client.