SSB fails with missing JAR file error

Condition

When creating a custom connector by uploading a JAR file and adding it to Streaming SQL Console, after a period of time the job submission fails when using the newly created connector with a JAR file missing error. This can be solved by changing the location of the storage directory in Cloudera Manager.

Cause

The uploaded JAR files are stored under /tmp/ssb_artifacts in SQL Stream Builder (SSB). This temporary folder can be cleaned up periodically by the Operating System (OS), which deletes the JAR files.

Remedy

  1. Open your cluster in Cloudera Manager.
  2. Select SQL Stream Builder from the list of services.
  3. Select Configuration.
  4. Search for Streaming SQL Engine Advanced Configuration Snippet (Safety Valve) for ssb-conf/application.properties in the search bar.
  5. Add ssb.artifact.storage.dir=[***NEW DIRECTORY PATH***] to the Safety Valve.
  6. Click Save.
  7. Restart the SQL Stream Builder service.