System requirements for EFM and NiFi Registry

Before you begin your installation of Cloudera Edge Management (CEM) software, carefully review the system requirements for Edge Flow Manager (EFM) and NiFi Registry to understand operating system, database, browser, and JDK support.

Operating system support

Operating System Version
RHEL/CentOS 7.x, 8.2
Debian 9
Ubuntu 16.04, 18.04

JDK support

JDK Version
OpenJDK JDK8, JDK11
Oracle JDK JDK8, JDK11

Supported databases

Database Version
PostgreSQL 9.x (x >= 6), 10.x, 11.x, 12.x
MySQL 5.6, 5.7, 8.0
MariaDB 10.2, 10.3, 10.4, 10.5, 10.6

Browser support

Browser Version
Chrome >=76.0 (latest version 80.0 at time of release)
Firefox >=68.0 (latest version 72.0 at time of release)

Other support

Package Version
Stunnel 5.x