Troubleshooting

This section helps you to narrow down a cause for an issue and provides a possible direction to resolve it.

Unable to see the S3 File Browser on the Hue web interface

Condition

Unable to see the S3 File Browser on the Hue web interface.

Cause

You may not have configured your Cloudera Data Warehouse (CDW) environment to have an S3 bucket that you can use to save data as part of the import process.

Solution

Add an S3 bucket in the CDW environment that you have access to. For more information, see the prerequisites section.

External File option is unavailable

Condition

External File option is unavailable on the Hue Importer dropdown list.

Cause

You may not have configured Hue to access the S3 bucket that you added in the environment.

Solution

Add the AWS access key and secret access key for your S3 bucket in the hue-safety-valve property. For more information, see the prerequisites section.

Error while accessing a directory in S3

Condition

Error stating "cannot access directory" while importing a file in Hue.

Cause

You may not have specified the right credentials in the hue-safety-valve property correctly.

Solution

Ensure that the account that owns the S3 bucket that you have added to your CDW environment has been added to the hue-safety-valve correctly.

Incorrect region error while uploading a file to S3

Condition

"Incorrect region" error while importing and uploading a file to S3 from your computer using Hue.

Cause

You may not have specified the AWS region where your S3 bucket is stored in the hue-safety-valve.

Solution

Ensure that the AWS region that you have specified in the hue-safety-valve is the same as the AWS region where your S3 bucket that you have added to your environment is managed.