System requirements

Review the system requirements before getting started with installing Cloudera Flow Management (CFM).

Supported versions of CDP

CFM 2.1.4 supports the following versions of CDP Private Cloud Base:

  • 7.1.7
  • 7.1.7 SP1

Supported JAVA Development Kits (JDK)

Supported JDKs:

  • Oracle Java™ SE Development Kit 8, Update 252 (JDK 8u252) and later
  • OpenJDK 1.8, Update 252 (JDK 8u252) and later
  • OpenJDK 11
  • Azul Zulu JDK 1.8, Update 252 (JDK 8u252) and later
  • Azul Zulu JDK 11

Other system requirements

  • ZooKeeper – You must install the ZooKeeper service available with your CDP Private Cloud Base cluster.
  • Four cores per NiFi node is the minimum number of cores required by Cloudera to be supported. Cloudera recommends eight cores per NiFi node as it usually provides the best starting point for the most common use cases.